分享我的生活
分享能使人快乐

手贱有在折腾MySQL server中libc.so.6(GLIBC_2.17) is needed

手贱有在折腾MySQL server,centos 6.7系统上
 
[xinyu2ru@localhost ~]$ rpm -i mysql-community-libs-compat-5.7.9-1.el7.i686.rpm
warning: mysql-community-libs-compat-5.7.9-1.el7.i686.rpm: Header V3 DSA/SHA1 Signature, key ID 5072e1f5: NOKEY
error: Failed dependencies:
libc.so.6(GLIBC_2.17) is needed by mysql-community-libs-compat-5.7.9-1.el7.i686
在这个系统上已经安装的libc
[xinyu2ru@localhost ~]$ yum list glibc*
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
* base: mirror.bit.edu.cn
* extras: mirrors.nwsuaf.edu.cn
* updates: mirrors.pubyun.com
Installed Packages
glibc.i686 2.12-1.166.el6_7.3 @updates
glibc-common.i686 2.12-1.166.el6_7.3 @updates
glibc-devel.i686 2.12-1.166.el6_7.3 @updates
glibc-headers.i686 2.12-1.166.el6_7.3 @updates
Available Packages
glibc-static.i686 2.12-1.166.el6_7.3 updates
glibc-utils.i686 2.12-1.166.el6_7.3 updates
硬是不懂后面的updates什么意思
反正就是glibc 2.12到头了,后面的安装必须由自己动手
思来想去,好吧,5.7.9不是装不上嘛!5.6总能装的上吧
 然后就顺利的在centos 6.7上装上了MySQL 5.6.27
MySQL-5.6.27-1.el6.i686.rpm-bundle.tar
最后想想,恩,MySQL-5.7.9应该是为centos7或者7.1准备的,但是网上的部分网友遇到了7.1也没法安装的问题,那么就可以用网上提供的glibc的rpm包直接安装了。
赞(0)
未经允许不得转载:RUBLOG-分享我的生活 » 手贱有在折腾MySQL server中libc.so.6(GLIBC_2.17) is needed

我想说 1

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
  1. #-49

    感谢楼主分享的,很实用!

    上海项目管理软件3年前 (2016-07-25)Reply